import re
regex = re.compile(r"rgba\([^$]")
test_str = ("box-shadow: 0 0 3px 1px rgba(black, 0.2);\n"
"-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);\n"
"background: rgba(236, 236, 236, 0.8);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")