const regex = /rgba\([^$]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rgba\\([^$]', 'g')
const str = `box-shadow: 0 0 3px 1px rgba(black, 0.2);
-webkit-box-shadow: 0 0 10px 0 rgba(\$black, 0.07);
background: rgba(236, 236, 236, 0.8);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}