import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rgba\\([^$]";
final String string = "box-shadow: 0 0 3px 1px rgba(black, 0.2);\n"
+ "-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);\n"
+ "background: rgba(236, 236, 236, 0.8);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}