re = /rgba\([^$]/
str = 'box-shadow: 0 0 3px 1px rgba(black, 0.2);
-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);
background: rgba(236, 236, 236, 0.8);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end