import Foundation
let pattern = #"rgba\([^$]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
box-shadow: 0 0 3px 1px rgba(black, 0.2);
-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);
background: rgba(236, 236, 236, 0.8);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)