# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\\/\\/(?!www))/$1www./g;t' <<< "the url is http://google.com http://www.google.com https://google.com https://google.com"