const regex = /(https?:\/\/(?!www))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/(?!www))', 'g')
const str = `the url is http://google.com http://www.google.com https://google.com https://google.com`;
const subst = `$1www.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);