import Foundation
let pattern = #"(https?:\/\/(?!www))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"the url is http://google.com http://www.google.com https://google.com https://google.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1www."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)