use strict;
my $str = 'the url is http://google.com http://www.google.com https://google.com https://google.com';
my $regex = qr/(https?:\/\/(?!www))/p;
my $subst = '$1www.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";