using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/(?!www))";
string substitution = @"$1www.";
string input = @"the url is http://google.com http://www.google.com https://google.com https://google.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}