import re
regex = re.compile(r"(https?:\/\/(?!www))")
test_str = "the url is http://google.com http://www.google.com https://google.com https://google.com"
subst = "$1www."
result = regex.sub(subst, test_str)
if result:
print(result)