re = /(https?:\/\/(?!www))/
str = 'the url is http://google.com http://www.google.com https://google.com https://google.com'
subst = '$1www.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result