$re = '/(https?:\/\/(?!www))/';
$str = 'the url is http://google.com http://www.google.com https://google.com https://google.com';
$subst = "$1www.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;