# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\\/\2\]/\1\3/gm;t' <<< "There's a problem with your [anchor:info]Account Details[/anchor].
There's a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].
We didn't recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to]."