using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\/\2\]";
string substitution = @"\1\3";
string input = @"There's a problem with your [anchor:info]Account Details[/anchor].
There's a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].
We didn't recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to].";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}