import Foundation
let pattern = #"^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\/\2\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
There's a problem with your [anchor:info]Account Details[/anchor].
There's a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].
We didn't recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to].
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)