const regex = /^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\/\2\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^[]+)\\[([^:\\]]+)[^\\]]*\\]([^[]+)\\[\\\/\\2\\]', 'gm')
const str = `There's a problem with your [anchor:info]Account Details[/anchor].
There's a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].
We didn't recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to].`;
const subst = `\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);