#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\/\2\]"
Local $sString = "There's a problem with your [anchor:info]Account Details[/anchor]." & @CRLF & _
"There's a problem with your [anchor:rewards]Sign Up For Rewards[/anchor]." & @CRLF & _
"We didn't recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to]."
Local $sSubst = "\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)