$re = '/^([^[]+)\[([^:\]]+)[^\]]*\]([^[]+)\[\/\2\]/m';
$str = 'There\'s a problem with your [anchor:info]Account Details[/anchor].
There\'s a problem with your [anchor:rewards]Sign Up For Rewards[/anchor].
We didn\'t recognize this account. Please re-enter your email or [link-to:register]Create An Account[/link-to].';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;