#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9\.]+)[\s]*([a-zA-Z%]*)"
Local $sString = "15px" & @CRLF & _
"45rem" & @CRLF & _
"15 px" & @CRLF & _
"45 rem" & @CRLF & _
"15%" & @CRLF & _
"15 %" & @CRLF & _
"20" & @CRLF & _
"20.5" & @CRLF & _
"35.99px" & @CRLF & _
"29.55555 %"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")