const regex = /([0-9\.]+)[\s]*([a-zA-Z%]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9\\.]+)[\\s]*([a-zA-Z%]*)', 'g')
const str = `15px
45rem
15 px
45 rem
15%
15 %
20
20.5
35.99px
29.55555 %`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}