package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9\.]+)[\s]*([a-zA-Z%]*)`)
var str = `15px
45rem
15 px
45 rem
15%
15 %
20
20.5
35.99px
29.55555 %`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}