// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9\.]+)[\s]*([a-zA-Z%]*)").unwrap();
let string = "15px
45rem
15 px
45 rem
15%
15 %
20
20.5
35.99px
29.55555 %";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}