re = /([0-9\.]+)[\s]*([a-zA-Z%]*)/
str = '15px
45rem
15 px
45 rem
15%
15 %
20
20.5
35.99px
29.55555 %'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end