using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9\.]+)[\s]*([a-zA-Z%]*)";
string input = @"15px
45rem
15 px
45 rem
15%
15 %
20
20.5
35.99px
29.55555 %";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}