import Foundation
let pattern = #"([0-9\.]+)[\s]*([a-zA-Z%]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
15px
45rem
15 px
45 rem
15%
15 %
20
20.5
35.99px
29.55555 %
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)