import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9\\.]+)[\\s]*([a-zA-Z%]*)";
final String string = "15px\n"
+ "45rem\n"
+ "15 px\n"
+ "45 rem\n"
+ "15%\n"
+ "15 %\n"
+ "20\n"
+ "20.5\n"
+ "35.99px\n"
+ "29.55555 %";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}