$re = '/([0-9\.]+)[\s]*([a-zA-Z%]*)/';
$str = '15px
45rem
15 px
45 rem
15%
15 %
20
20.5
35.99px
29.55555 %';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);