# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\<div.*\>((.*|\s|\r|\n)*)\<\\/div\>/$1/gm;t' <<< "<div class=\"1\" >quero pegar
AQUI DENTRO PODE TER
quebra de linha...
paragrafo...
espaços
várias outras tags html...
qualquer coisa...
<p> Teste </p>
<p><span> Teste <span> </p>
</div>"