use strict;
my $str = '<div class="1" >quero pegar
AQUI DENTRO PODE TER
quebra de linha...
paragrafo...
espaços
várias outras tags html...
qualquer coisa...
<p> Teste </p>
<p><span> Teste <span> </p>
</div>';
my $regex = qr/\<div.*\>((.*|\s|\r|\n)*)\<\/div\>/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";