# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\<div.*\>((.*|\s|\r|\n)*)\<\/div\>"
test_str = ("<div class=\"1\" >quero pegar\n\n"
" AQUI DENTRO PODE TER\n"
" quebra de linha...\n"
" paragrafo...\n"
" espaços\n"
" várias outras tags html...\n"
" qualquer coisa...\n"
" <p> Teste </p>\n\n"
" <p><span> Teste <span> </p>\n"
"</div>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.