import Foundation
let pattern = #"\<div.*\>((.*|\s|\r|\n)*)\<\/div\>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="1" >quero pegar
AQUI DENTRO PODE TER
quebra de linha...
paragrafo...
espaços
várias outras tags html...
qualquer coisa...
<p> Teste </p>
<p><span> Teste <span> </p>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)