const regex = /\<div.*\>((.*|\s|\r|\n)*)\<\/div\>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<div.*\\>((.*|\\s|\\r|\\n)*)\\<\\\/div\\>', 'gm')
const str = `<div class="1" >quero pegar
AQUI DENTRO PODE TER
quebra de linha...
paragrafo...
espaços
várias outras tags html...
qualquer coisa...
<p> Teste </p>
<p><span> Teste <span> </p>
</div>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);