package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\<div.*\>((.*|\s|\r|\n)*)\<\/div\>`)
var str = `<div class="1" >quero pegar
AQUI DENTRO PODE TER
quebra de linha...
paragrafo...
espaços
várias outras tags html...
qualquer coisa...
<p> Teste </p>
<p><span> Teste <span> </p>
</div>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}