re = /\<div.*\>((.*|\s|\r|\n)*)\<\/div\>/m
str = '<div class="1" >quero pegar
AQUI DENTRO PODE TER
quebra de linha...
paragrafo...
espaços
várias outras tags html...
qualquer coisa...
<p> Teste </p>
<p><span> Teste <span> </p>
</div>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result