import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<div.*\\>((.*|\\s|\\r|\\n)*)\\<\\/div\\>";
final String string = "<div class=\"1\" >quero pegar\n\n"
+ " AQUI DENTRO PODE TER\n"
+ " quebra de linha...\n"
+ " paragrafo...\n"
+ " espaços\n"
+ " várias outras tags html...\n"
+ " qualquer coisa...\n"
+ " <p> Teste </p>\n\n"
+ " <p><span> Teste <span> </p>\n"
+ "</div>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}