# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:.*?[\\\\/])?app[\\\\/]\w+[\\\\/]|([^\\\\/\n]+?)(?:\.rb$|([\\\\/]))/<$1>[$2]/gm;t' <<< "app/service/namespace/important_thing/my_class.rb
D:\app\service\namespace\important_thing\my_class.rb"