re = /^(?:.*?[\\\/])?app[\\\/]\w+[\\\/]|([^\\\/\n]+?)(?:\.rb$|([\\\/]))/m
str = 'app/service/namespace/important_thing/my_class.rb
D:\\app\\service\\namespace\\important_thing\\my_class.rb'
subst = '<$1>[$2]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result