$re = '/^(?:.*?[\\\\\/])?app[\\\\\/]\w+[\\\\\/]|([^\\\\\/\n]+?)(?:\.rb$|([\\\\\/]))/m';
$str = 'app/service/namespace/important_thing/my_class.rb
D:\\app\\service\\namespace\\important_thing\\my_class.rb';
$subst = "<$1>[$2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;