#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:.*?[\\\/])?app[\\\/]\w+[\\\/]|([^\\\/\n]+?)(?:\.rb$|([\\\/]))"
Local $sString = "app/service/namespace/important_thing/my_class.rb" & @CRLF & _
"D:\app\service\namespace\important_thing\my_class.rb"
Local $sSubst = "<$1>[$2]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)