// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*?[\\\/])?app[\\\/]\w+[\\\/]|([^\\\/\n]+?)(?:\.rb$|([\\\/]))").unwrap();
let string = "app/service/namespace/important_thing/my_class.rb
D:\\app\\service\\namespace\\important_thing\\my_class.rb";
let substitution = "<$1>[$2]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}