import Foundation
let pattern = #"^(?:.*?[\\\/])?app[\\\/]\w+[\\\/]|([^\\\/\n]+?)(?:\.rb$|([\\\/]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
app/service/namespace/important_thing/my_class.rb
D:\app\service\namespace\important_thing\my_class.rb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1>[$2]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)