package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*?[\\\/])?app[\\\/]\w+[\\\/]|([^\\\/\n]+?)(?:\.rb$|([\\\/]))`)
var str = `app/service/namespace/important_thing/my_class.rb
D:\app\service\namespace\important_thing\my_class.rb`
var substitution = "<$1>[$2]"
fmt.Println(re.ReplaceAllString(str, substitution))
}