const regex = /^(?:.*?[\\\/])?app[\\\/]\w+[\\\/]|([^\\\/\n]+?)(?:\.rb$|([\\\/]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*?[\\\\\\\/])?app[\\\\\\\/]\\w+[\\\\\\\/]|([^\\\\\\\/\\n]+?)(?:\\.rb$|([\\\\\\\/]))', 'gm')
const str = `app/service/namespace/important_thing/my_class.rb
D:\\app\\service\\namespace\\important_thing\\my_class.rb`;
const subst = `<$1>[$2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);