#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)"
Local $sString = "C:\Users\J\Documents\project\code\win32_jesse.cpp(772,70) : error: expected ';' after expression" & @CRLF & _
"AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)" & @CRLF & _
" ^" & @CRLF & _
" ;" & @CRLF & _
"1 error generated."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")