package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)`)
var str = `C:\Users\J\Documents\project\code\win32_jesse.cpp(772,70) : error: expected ';' after expression
AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)
^
;
1 error generated.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}