// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)").unwrap();
let string = "C:\\Users\\J\\Documents\\project\\code\\win32_jesse.cpp(772,70) : error: expected ';' after expression
AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)
^
;
1 error generated.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}