re = /([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)/
str = 'C:\\Users\\J\\Documents\\project\\code\\win32_jesse.cpp(772,70) : error: expected \';\' after expression
AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)
^
;
1 error generated.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end