import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\n]+?\\.cpp)\\((\\d+),(\\d+)\\) : error: ([^\\n]+)";
final String string = "C:\\Users\\J\\Documents\\project\\code\\win32_jesse.cpp(772,70) : error: expected ';' after expression\n"
+ "AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)\n"
+ " ^\n"
+ " ;\n"
+ "1 error generated.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}