const regex = /([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\n]+?\\.cpp)\\((\\d+),(\\d+)\\) : error: ([^\\n]+)', 'g')
const str = `C:\\Users\\J\\Documents\\project\\code\\win32_jesse.cpp(772,70) : error: expected ';' after expression
AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)
^
;
1 error generated.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}